VoxelNodes Platform Upgrade & Infrastructure Maintenance
Resolved
Jun 3, 2026 at 7:35am UTC
Maintenance ended
Affected services
Created
Jun 3, 2026 at 5:35am UTC
VoxelNodes will undergo scheduled maintenance to improve platform stability, security, and user experience.
During this maintenance window, we will:
• Remove legacy panel customizations and perform a clean backup of our Pterodactyl environment.
• Update our billing platform (Paymenter) to the latest stable release.
• Deploy the Arix Theme and Arix Addon Pack to the client panel.
• Deploy the LucentUI theme to the billing area.
• Perform compatibility checks, dependency validation, asset compilation, and service verification.
Customers may experience temporary interruptions to the client panel, billing area, or management features during the maintenance period. Active game servers and VPS instances are expected to remain unaffected unless otherwise announced.
We appreciate your patience as we continue improving the VoxelNodes platform.
Affected services